In GitLab CE/EE versions 18.11 before 18.11.1 medium severity vulnerability CVE-2026-5377 was detected. This vulnerability allows attackers to access titles of confidential or private issues in public projects due to improper access control in the issue description rendering process. To address this issue users must upgrade to 18.11.1 version. For more details, visit https://nvd.nist.gov/vuln/detail/CVE-2026-5377.
Read more Developer ToolsIn GitLab CE/EE versions 16.1.0 before 18.9.6, 18.10 before 18.10.4, and 18.11 before 18.11.1 high severity vulnerability CVE-2026-5262 was detected. This vulnerability allows attackers to access tokens in the Storybook development environment due to improper input validation. To address this issue users must upgrade to 18.9.6, 18.10.4, or 18.11.1 versions. For more details, visit https://nvd.nist.gov/vuln/detail/CVE-2026-5262.
Read more Developer ToolsIn GitLab CE/EE versions 18.10 before 18.10.4 and 18.11 before 18.11.1 high severity vulnerability CVE-2026-5816 was detected. This vulnerability allows attackers to execute arbitrary JavaScript in a user’s browser session due to improper path validation under certain conditions. To address this issue users must upgrade to 18.10.4 or 18.11.1 versions. For more details, visit https://nvd.nist.gov/vuln/detail/CVE-2026-5816.
Read more Developer ToolsIn HAProxy versions 2.6 through 3.3.5 a medium severity vulnerability CVE-2026-33555 was detected. This vulnerability allows attackers to cause desynchronization issues with the backend server by exploiting a flaw in the HTTP/3 parser, which fails to verify that the received body length matches the announced Content-Length when a stream is closed via an empty payload frame. This can be exploited for request smuggling, potentially leading to unauthorized access or cache poisoning. To address this issue users must upgrade to version 3.3.6 or other patched stable releases (2.6.25, 3.0.19, 3.2.15). For more details, visit https://nvd.nist.gov/vuln/detail/CVE-2026-33555.
Read more Application DevelopmentIn Apache Kafka versions 4.1.0 and 4.1.1 a critical severity vulnerability CVE-2026-33557 was detected. This vulnerability allows attackers to bypass authentication and impersonate any user by providing an unvalidated JWT token, as the default validator fails to check signatures, issuers, or audiences. To address this issue users must upgrade to version 4.1.2, 4.2.0, or later, or explicitly set the validator class to BrokerJwtValidator. For more details, visit https://nvd.nist.gov/vuln/detail/CVE-2026-33557.
Read more Data AnalyticsIn Apache Kafka versions up to 3.9.1 and 4.0.0 a medium severity vulnerability CVE-2026-33558 was detected. This vulnerability allows attackers to access sensitive information, including authentication credentials and delegation tokens, because the NetworkClient component outputs entire requests and responses—such as SaslAuthenticate and AlterConfigs—when the DEBUG log level is enabled. To address this issue users must upgrade to version 3.9.2, 4.0.1, or later. For more details, visit https://nvd.nist.gov/vuln/detail/CVE-2026-33558.
Read more Data AnalyticsIn Kimai versions 2.52.0 and below a high severity vulnerability CVE-2026-40486 was detected. This vulnerability allows attackers with standard user accounts to modify restricted attributes such as hourly_rate and internal_rate via the User Preferences API, bypassing intended permission checks. This unauthorized financial tampering directly impacts invoice generation and timesheet calculations. To address this issue users must upgrade to version 2.53.0. For more details, visit https://nvd.nist.gov/vuln/detail/CVE-2026-40486.
Read more Project ManagementIn Grafana versions 8.0.1 through 12.3.0 a high severity vulnerability CVE-2025-12141 was detected. This vulnerability allows attackers with Editor permissions to edit contact points created by other users and modify endpoint URLs to a controlled server. By invoking the test functionality, attackers can capture and extract redacted secure settings, such as authentication credentials for third-party services like Slack tokens. To address this issue users must upgrade to version 12.3.1 or higher. For more details, visit https://nvd.nist.gov/vuln/detail/CVE-2025-12141.
Read more Data AnalyticsIn Mattermost versions 10.11.x through 10.11.12 a medium severity vulnerability CVE-2026-27769 was detected. This vulnerability allows a malicious remote server connected via the Connected Workspaces feature to change the displayed status of local users by exploiting a failure to validate user ownership within the Connected Workspaces API. To address this issue, users must upgrade to version 11.5.0 or 10.11.13. For more details, visit https://nvd.nist.gov/vuln/detail/CVE-2026-27769.
Read more Communication